www.hourfleet.com reporting "Your connection is not private"
Incident Report for Hourfleet
Resolved
A new certificate has been issued, and has resolved this issue.
Posted over 1 year ago. Jul 05, 2018 - 22:27 NZST
Identified
Our digital certificate has expired and another is being installed. We apologise for the inconvenience .. and for that scary browser message. Rest assured your browsing on our site is completely safe. Normal service will resume soon.
Posted over 1 year ago. Jul 05, 2018 - 22:13 NZST
This incident affected: Hourfleet App.