SMS car instructions not received
Incident Report for Hourfleet
Resolved
This incident is now downgraded to Major.

This service has been patched (as of Friday 29th June 2018) , and carkits that were affected have either already been patched, or have been scheduled to be patched in the near future.

It was found through experimentation that the SMS provider only occasionally switches the short codes for reasons that are not well understood. We suspect are traffic related.

While the issue still persists in some carkits that are not yet patched, the service itself is no longer suffering an outage.
Posted over 1 year ago. Jul 05, 2018 - 09:44 NZST
Update
We have confirmed that our local carrier captures text instructions related via Plivo.com, allocating them to a range of 4-digit shortcodes or Longcodes before they are forwarded to our in-car device. This allocation pool is the root cause of the problem. Work is underway to remove this dependency on internal carrier process/practices, and the resolution will necessitate installation of new firmware for each device. We will be in touch with customers individually to co-ordinate this work. Please be assured that this remains a P1 issue for us, and our team is working around the clock to resolve it
Posted over 1 year ago. Jun 27, 2018 - 16:39 NZST
Update
We are continuing to work on a fix for this issue.
Posted over 1 year ago. Jun 24, 2018 - 18:27 NZST
Identified
We detected that SMS lock/unlock instructions sent from the Hourfleet backend were being received by carkit devices from the wrong sender ID (shortcode/longcode), and therefore these messages were being rejected as suspicious.

We have been working since with the SMS provider (Plivo) to resolve this issue.
No components were marked as affected by this incident.
Posted over 1 year ago. Jun 22, 2018 - 00:00 NZST
This incident affected: Hourfleet App and Carkits (devices fitted to cars).